Cisco 5000 NX-OS pour les nuls !

17 Oct 2014 par jj, Pas de commentaire »
Cisco Nexus 5020

Cisco Nexus 5020

Bonjour,

Aujourd’hui, je vous propose quelques notes pour la réinstallation d’un firmware Cisco NX- et quelques paramètres de base.
J’ai donc reçu au bureau un switch Cisco 5020 avec 40 ports 10G (Attention seul les 16 premiers ports peuvent être passés en 1G)

-1er étape : récupérer le firmware
Le firmware se décompose en deux parties, le kickstart et l’image système.
Pour le récupérer, soit vous avez un contrat de support chez Cisco, soit vous vous débrouillez en cherchant sur le net …
Pour la version Cisco 5000, vous devez chercher les fichiers :
n5000-uk9-kickstart.5..X.NX..bin
n5000-uk9.5.X.X.NX.X.bin
Par exemple dans mon cas :
n5000-uk9-kickstart.5.2.1.N1.7.bin
n5000-uk9.5.2.1.N1.7.bin
http://certcollection.org/forum/topic/223888-nexus-5k-images-413421521/

-2eme étape : paramétrer un serveur TFTP
Perso ayant un , j’ai utilisé celui intégré à OSX en modifiant quelque peu le fichier de configuration :
dans le terminal, tapez :
sudo nano /System/Library/LaunchDaemons/tftp.plist
Puis modifier votre fichier pour qu’il soit comme ceci :

Nous allons ensuite lancer le service TFTP :
sudo launchctl load -F /System/Library/LaunchDaemons/tftp.plist
Pour vérifier qu’il est bien lancé :
sudo launchctl list | grep tftp
Et cette commande servira à la fin pour arrêter le service TFTP :
sudo launchctl unload -F /System/Library/LaunchDaemons/tftp.plist

Comme vous avez pu le remarquer dans le fichier de configuration du service TFTP, le dossier racine du serveur est :
/private/tftpboot
Evidement, vous pouvez le changer à votre convenance.

-3eme étape : copie des fichier kickstart et système dans le dossier /private/tftpboot

-4eme étape, démarrer le switch en mode « loader »
Evidement vous êtes connecté au switch sur le port console avec votre terminal préféré …
dans l’invite de commande du switch, tapez la commande reload, pendant le démarrage du switch, pressez les touches Ctrl+Shift+R
Vous etes enfin sur le mode loader, nous allons ensuite paramétrer une ip sur l’interface ethernet mgmt0, c’est par le biais de cette interface que le switch va télécharger les fichiers du firmware sur le serveur TFTP.
Reliez donc votre machine avec le serveur TFTP paramétré sur le port mgmt0
Nous allons choisir deux IP sur le meme réseau pour simplifier la communication entre le switch et le serveur TFTP
sur le prompt « loader », tapez la commande :
set ip 192.168.1.99 255.255.255.0
Sur votre machine hébergeant le service TFTP, parametrez l’ip suivante sur la carte réseau relié au port du switch mgmt0, par exemple :
IP : 192.168.1.100
NETMASK : 255.255.255.

A ce stade, vous êtes prêt à télécharger les fichiers du firmware !!!

-5eme étape : copie des fichiers du firmware et lancement

Sur le prompt « loader » du switch, tapez :
boot tftp://192.168.1.234/private/tftpboot/n5000-u9-kickstart.5.2.1.N1.7.bin
vous devriez voir :

Address: 192.168.1.99
Netmask: 255.255.255.0
Server: 192.168.1.100
Gateway: 0.0.0.0
Booting: /private/tftpboot/n5000-uk9-kickstart.5.2.1.N1.7.bin console=ttyS0,960
0n8nn

Puis :

Cisco Nexus Operating System (NX-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2013, Cisco Systems, Inc. All rights reserved.
The copyrights to certain works contained in this software are
owned by other third parties and used and distributed under
license. Certain components of this software are licensed under
the GNU General Public License (GPL) version 2.0 or the GNU
Lesser General Public License (LGPL) Version 2.1. A copy of each
such license is available at
http://www.opensource.org/licenses/gpl-2.0.php and

http://www.opensource.org/licenses/lgpl-2.1.php

Si vous avez scrupuleusement suivi le tuto, le fichier doit se télécharger, sinon vérifiez bien que le service TFTP fonctionne en se connectant sur la machine en ligne de commande sur l’interface localhost.
Si le test réussi, vous avez surement un problème de liaison lié au cable ou à un (désactivez le temporairement)

Une fois le kickstart booté, nous allons paramétrer à nouveau l’interface mgmt0 pour télécharger l’image système :
Tapez :
conf t
Puis :
interface mgmt 0
Ensuite donnons une ip à l’interface mgmt0 :
ip address 192.168.1.99 255.255.255.0
Démarrons l’interface avec la commande :
no shutdown
Et sortons de l’interface et du mode config :
exit
exit
Nous allons ensuite copier le firmware :
copy tftp: bootflash:
Dans :
Enter source filename:
Tapez :
/private/tftpboot/n5000-uk9.5.2.1.N1.7.bin
Puis dans :
Enter hostname for the tftp server:
Tapez :
192.168.1.100
Le fichier se télécharge du serveur TFTP
Copions ensuite le kickstarter :

copy tftp: bootflash:

Enter source filename:
/private/tftpboot/n5000-uk9-kickstart.5.2.1.N1.7.bin

Enter hostname for the tftp server:
192.168.1.100

Une fois les fichiers téléchargés, nous allons enfin booter sur le firmware :
switch(boot)# load n5000-uk9.5.2.1.N1.7.bin

Une fois le firmware booter, vous devriez avoir un setup qui simplifie les parametrages de base tels que le mot de passe, l’activation du telnet, du et de l’interface web, le paramétrage IP de l’interface mgmt0 (interface d’administration), le serveur NTP …

Une fois vos paramètres de base effectués, nous allons spécifier au bootloader les fichiers de démarrage (le kickstarter et le firmware)
Pour cela, tapez la commande suivante pour le kickstarter :
boot kickstart bootflash:n5000-uk9-kickstart.5.2.1.N1.7.bin
boot system bootflash:n5000-uk9.5.2.1.N1.7.bin

N’oubliez pas de sauvegarder votre configuration par :
copy running-config startup-config

Et voilà, vous avez un switch Nexus tout propre avec le dernier firmware en vogue, vous pouvez maintenant vous atteler au paramétrage des vlans et faire votre tambouille.

 

 

MEMO : 

Affichage de la version du firmware et du bootloader :

NEXUS#show version

Sauvegarde de la configuration (sinon au redémarrage vous perdrez tout ce que vous avez fait !) :

NEXUS#copy running-config startup-config

Passer un des 16 premiers port en 1 gigabyte :

NEXUS(config)#interface fastEthernet 1/1
NEXUS(config-if)#speed 1000
NEXUS(config-if)#no shutdown

Créer un vlan :

NEXUS(config)#vlan 2
NEXUS(config-vlan)#name toto

Suppression d’un vlan :

NEXUS(config)#no vlan 2

Affichage des vlans :

NEXUS#show vlan

Ajout de fonctionnalités interface aux vlan (permet d’ajouter une ip à un vlan entre autre) :

NEXUS(config)#feature interface-vlan

Affectation d’une IP à un vlan :

NEXUS(config)#interface vlan 11
NEXUS(config-if)#ip address 192.168.11.100/24

Ajout d’une route static :

NEXUS(config)#ip route 192.168.92.0/24 192.168.11.1

Ajout d’une route par défaut :

NEXUS(config)#ip route 0.0.0.0/0 192.168.11.1

Affectation d’un port à un vlan :

NEXUS(config)#interface fastEthernet 0/1
NEXUS(config-if)#switchport mode access
NEXUS(config-if)#switchport access vlan 2

Création d’un trunk :

NEXUS(config)#interface Ethernet 1/1
NEXUS(config-if)#description trunk vers switch
NEXUS(config-if)#switchport mode trunk

Affectation d’un vlan au trunk précédemment créer :

NEXUS(config)#interface Ethernet 1/40
NEXUS(config-if)#switchport access vlan 10

Sauvegarde de la configuration :

NEXUS#copy running-config startup-config

Autoriser des SFP qui ne sont pas microcodé CISCO :

NEXUS(config)#service unsupported-transceiver

Activer le Jumbo frame :

NEXUS(config)#systemjumbomtu

Activer le protocole UDLD sur un port en particulier (Unidirectional Link Detection, permet de vérifier le bon fonctionnement des liens, de leur type, vitesse etc …. Evite également les problématiques de boucle réseau) :

NEXUS# configure terminal
NEXUS(config)# feature udld
NEXUS(config)# interface ethernet 1/4
NEXUS(config)# udld enable

paramétrer des PVLAN (Private Vlan permettant que certains ports du switch ne se voient qu’entre eux) :

Un PVLAN tout seul dans son coin :
NEXUS# configure terminal
NEXUS(config)# feature private-vlan
NEXUS(config)# vlan 20
NEXUS(config-vlan)# private-vlan isolated

PVLANDialogue entre PVLANs : Il faut créer un PVLAN primaire et associer les PVLANs que l’on souhaite connecter :

NEXUS# configure terminal
NEXUS(config)# vlan 5
NEXUS(config-vlan)# private-vlan primary
NEXUS(config-vlan)# private-vlan association 20,21,22

Les PVLAN 20,21,22 dialogueront au niveau 2 sur le PVLAN primaire No 5.

NEXUS# configure terminal
NEXUS(config)# feature fcoe

Pour le désactiver : 

NEXUS(config)# no feature fcoe

PVLANDialogueDésactiver le traffic LAN pour dédier un port à FCOE :

NEXUS# configure terminal
NEXUS(config-vlan)#int eth1/4
NEXUS(config-if)# shutdown lan
NEXUS(config-if)# ^Z

PVLANDialogueDésactiverFaire un fcmap pour empecher une connexion d’une autre adresse mac : 
NEXUS# configure terminal
NEXUS(config)# fcoe fcmap 0e.fc.00…

DialogueDésactiverFaireDéterminer la priorité de la switch fabric (par défaut 128, la plus haute 0 et la plus basse 255) :

NEXUS# configure terminal
NEXUS(config)# fcoe fcf-priority 128

Paramétrer l’intervalle d’annonce de la fabric sur le SAN (par défaut 8 secondes, valeur allant de 4 à 60) : 

NEXUS# configure terminal
NEXUS(config)# fcoe fka-adv-period 30

Afficher la configuration FCOE : 

NEXUS# show fcoe
Global FCF details
FCF-MAC is 00:0e:cc:7e:35:cd
FC-MAP is 0e:fc:00
FCF Priority is 128
FKA Advertisement period for FCF is 30 seconds
Bon courage ;)

Étiquettes : , , , , , ,

Réagissez

Raspberry Pi 2 ou 3 et Raspbian Jessie - VLC 2.4 et accélération matériel (hardware acceleration)

Raspberry Pi 2 ou 3 et Raspbian Jessie – VLC 2.4 et accélération matériel (hardware acceleration)

Aujourd’hui je vais à nouveau publier une mise à jour de l’article : Raspberry Pi 2 – VLC et accélération matériel (hardware [&hellip

Raspberry Pi 2 ou 3 et Raspbian Jessie - VLC 2.2 et accélération matériel (hardware acceleration)

Raspberry Pi 2 ou 3 et Raspbian Jessie – VLC 2.2 et accélération matériel (hardware acceleration)

UPDATE : Raspberry Pi 2 ou 3 et Raspbian Pixel – VLC 2.4 et accélération matériel (hardware acceleration) Aujourd’hui je vais [&hellip

Compilation de la derniere version de FFMPEG

Compilation de la derniere version de FFMPEG

Bonjour à tous, Aujourd’hui un petit tuto pour avoir la dernière version de ffmpeg, ce tutoriel à été utilisé maintes [&hellip

Raspberry Pi 2 - VLC et accélération matériel (hardware acceleration)

Raspberry Pi 2 – VLC et accélération matériel (hardware acceleration)

UPDATE : Raspberry Pi 3 et Raspbian Pixel – VLC 2.4 et accélération matériel (hardware acceleration) Ayant un petit projet de [&hellip

FFMPEG - Diffuser un flux ip multicast en adaptative smooth streaming

FFMPEG – Diffuser un flux ip multicast en adaptative smooth streaming

Un petit script bien utile pour délivrer un flux video multicast en adaptative smooth streaming

Installation de Transform Manager

Installation de Transform Manager

Prérequis – résumé : Télécharger Transform Manager Télécharger IIS Media Services 4.1 Télécharger IIS Managment console Télécharger .NET Framework 3.5 [&hellip

Suivez moi !

Follow Me! Follow Me! Follow Me! Follow Me!

Une ptite donation

Si vous voulez contribuer à faire vivre ce site :

Chercher

%d blogueurs aiment cette page :